[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Substituting Donald Beckers nic driver into kickstart boot disk....



Unfortunately I am stuck with a bunch of Crappy Linksys V 4.1 ethernet
cards... Although they are not supported  out of the box in 6.2 or 7.0  I
have gotten them to work by inserting Donald Beckers network drivers.  Now I
am trying to do a network nfs kickstart with these same cards. I am going
crazy trying to figure out how to substitute those driver modules into the
kickstart framework....( this is my first kickstart )

So here is what I did so far.... I have some 3Com Vortex cards(these work
out of the box with 6.2 installer) laying around... so I got a kickstart
over NFS using DHCP working just fine with these cards.  Then(knowing that I
have a working process) I I tried to substitute in Donald
Beckers(www.scyld.com) drivers into modules.cgz in the initrd from the
bootnet-20000407.img. I have tried a couple variations on this but none of
them seem to work I always get the same result.  The kickstart falls through
too looking for /tmp/kickstart.cfg..... ....

On Alt F4 console I get not indication of the 3c59x.o module loading
successfully...
On the Alt F3 console I get the following....

probing buses
finish bus probing
found suggestion of 3cf9x
found 3c59x device
found devices justProbe is 0
going to insmod pci-scan.o(path is null)
going to insmod 3c59x.o(path is null)
sending DHCP request through eth0
Pump told us : siocsifaddr:no such device
no dhcp response

Ok so what I have done...

 downloaded 2.2.14-5.0 source from RedHat.... added Beckers drivers.... did
make modules..... then got the modules.cgz from the bootnet-20000407.img
initrd and replaced the networking modules with the new ones I compile and
put them back in the modules.cgz -> back in the initrd....  The first time I
put  the modules in the original 2.2.14-5.0BOOT dir... second time I change
the dir name to 2.2.14-5.0.. dir... (I am not really sure how the kernel
finds the modules... is /modules/modules.cgz a default place for the kernel
to look?)... I also modified the modules.dep file in initrd to include the
dependency of the D Becker network drivers on pci-scan.o modules(that part
seem to be working as shown in the output)..

So does anybody have any idea what I am doing wrong?.....

Any help is greatly appreciated...Thanks in advance....

Scott Shealy





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]