[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Inconsistent Kickstart Problem (7.1).



In the %post section of my kickstart config file, I'm running a shell script
which installs a set of RPMs.  Rarely, the RPM command will behave oddly,
and I can't figure out why.  Here's an excerpt from the kickstart config
file:

------------- ks.cfg BEGIN -------------
...
%post --nochroot
...
/mnt/source/posttools/rpm_upgrade.sh
------------- ks.cfg END -------------

And here's the command I'm running in rpm_upgrade.sh:

------------- rpm_upgrade.sh BEGIN -------------
...
rpm --root /mnt/sysimage -Uv --nodeps --force $MYRPM
...
------------- rpm_upgrade.sh END -------------

Here's the error I see:

------------- CUT -------------
error: unpacking of archive failed on file /opt/jini/jre1.3.1/lib/rt.jar:
cpio: MD5 sum mismatch
...
error: unpacking of archive failed on file
/opt/swiftmq/conf/localrouter.swiftmq.properties.template: cpio: MD5 sum
mismatch
/mnt/source/posttools/rpm_upgrade.sh: line 60:   928 Segmentation fault
rpm --root $DSTROOT -Uv --nodeps --force $RPM_UPGRADE_DIR/$MYRPM
------------- CUT -------------

When I re-kicked the system, there were NO errors.

The kickstart is happening via NFS, and the package $MYRPM also resides on
the NFS filesystem (hence the --nochroot flag to %post).

Has anyone seen similar inconsistent behavior?




Vijay





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]