[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: kickstart - ok via floppy, fails when booting from cd



FYI --

The problem was not with Kickstart per say, rather with my kickstart
file.  Anaconda did not like my ks.cfg file for some reason.  

I'm now guessing -- anaconda reads the entire file when it gets it. I'm
not sure what it does next, but I think it somehow acts on what it finds
in %post.  I'm guessing this as I had a rather long %post section and in
the middle I had an exit.  I think anaconda somehow saw that exit in the
%post section at the start and thus exited as it thought it should do.


Regards,
Chad




On Mon, 2002-06-03 at 19:46, Chad M. Stewart wrote:
> 
> I've been testing my %post section, over and over till I get my server
> 100% during install just the way I want it. :)
> 
> During all this my floppy drive went bad. So I mounted
> dosutils/autoboot/cdboot.img and copied over my msg file and the
> modified version of syslinux.cfg and then created a bootable cdrom.
> 
> It boots from the cdrom fine.  I select the SMC driver (Thank you for
> making it part of the default package.:))  and it goes to the kickstart
> file. (GET /./fs.cfg HTTP/1.0" 200 9272) and then blows up with some
> text on the first virtual terminal "install exited abnormally --
> received signal 11"  on vt3 I see
> 
> sending dhcp request through device eth0
> nodns is 0
> reverse name lookup failed
> ks location: http://kickstart/fs.cfg
> transferring http://kickstart//./fs.cfg to a fd
> 
> 
> And now I've no choice but to reboot...  
> 
> 
> Any ideas on how to work around this?
> 
> 
> 
> Thanks,
> Chad
> 
> 
> 
> _______________________________________________
> Kickstart-list mailing list
> Kickstart-list redhat com
> https://listman.redhat.com/mailman/listinfo/kickstart-list






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]