[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FTP install with kickstart



I am trying to do a remote installation of RH 7.2 using a ks.cfg file and an FTP server.  I have made a boot floppy from the bootnet.img image and put my ks.cfg file on it.  I have been successful in doing an installation by typing 'linux ks=floppy' at the boot prompt.  This was all done to make sure that my ks.cfg file worked like I wanted it to.  When I try to do a remote installation across the network, I get an error and am unable to complete the installation.  First, some background.  For the remote install, I am first putting a DOS image onto the harddrive of the remote computer and then copying over my ks.cfg file, as well as the initrid.img and vmlinuz files from the dosutils\autoboot directory on the RedHat CD and loadlin.exe from the dosutils directory.  I then run 'c:\loadlin c:\vmlinuz initrd=c:\initrd.img ks=hd:sda1/ks.cfg'  This seems to be working, and I am not prompted for any user input.  About halfway through the status bar for the post install configuratio!
n, I get an error message:

/usr/sbin/probe: error while loading shared libraries: /lib/libc.so.6: cannot read file data: Error 21

It then continues loading the bootloader, and then says that the 'install exited abnormally -- received signall 11'  and sends the termination signals and waits for a reboot.  But it seems that everything is installed, because once you reboot the machine you have RH 7.2 loaded up, just like you wanted.  The problem here is that the error is keeping the installation from automatically rebooting, even thought I have 'reboot' in the ks.cfg file.  You have to manually go and reboot the machine.  Since I can use the exact same ks.cfg file from the floppy successfully, I don't think it's to blame.  Any ideas or help would be great.  I've included most of the ks.cfg file below.

# Kickstart file automatically generated by anaconda.

install
lang en_US
langsupport --default en_US en_US
keyboard us
url --url ftp://12.12.12.1/images
mouse generic3ps/2 --device psaux
xconfig --card "RIVA TNT2" --videoram 16384 --hsync 31.5 --vsync 50-61 --resolution 1024x768 --depth 16 --startxonboot
network --device eth0 --bootproto dhcp --nameserver 0.0.0.0
rootpw --iscrypted <PASSWORD HERE>
firewall --disabled
authconfig --enableshadow --enablemd5
timezone America/Chicago
bootloader
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --all --drives=sda
part /boot --fstype ext3 --size=50 --ondisk=sda
part / --fstype ext3 --size=1100 --grow --ondisk=sda
part swap --size=512 --grow --maxsize=1024 --ondisk=sda
reboot

%packages
@ Printing Support
@ Classic X Window System
@ X Window System
@ GNOME
@ Sound and Multimedia Support
@ Network Support
@ Dialup Support
@ Messaging and Web Tools
@ Workstation Common
balsa
rsync
samba-common
compat-libstdc++
mozilla-mail
gaim
SDL_image
libesmtp
magicdev
w3c-libwww
libpcap
pan
psgml
SDL
rp3
rhn_register-gnome
redhat-config-network
xawtv
nmap-frontend
htmlview
up2date-gnome
mozilla-psm
smpeg
samba-client
ical
licq
xisdnload
SDL_net
licq-gnome
pam_smb
exmh
netscape-communicator
gnome-media
SDL_mixer
openssh-askpass-gnome
tetex-xdvi
xmms-gnome
emacs-X11
telnet-server
xpdf
linuxconf
ucd-snmp
xmms
openssh-askpass
wine
usbview
netscape-common
galeon
gd
gq

%post
/sbin/chkconfig telnet on reset
/usr/sbin/useradd diags
chfn -f 'Corporate Diagnostics' diags
/usr/sbin/usermod -p <PASSWORD HERE> diags


Mark





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]