[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: minimally changing rh72 disk-1

What is the error you are getting?


                      "Skahan, Vince"                                                                                           
                      <vince skahan boeing        To:       "'kickstart-list redhat com'" <kickstart-list redhat com>           
                      .com>                       cc:                                                                           
                      Sent by:                    Subject:  minimally changing rh72 disk-1                                      
                      06/21/2002 11:18 AM                                                                                       
                      Please respond to                                                                                         

I'm trying to squeeze the two rh72 disks down to one
and wanted to try something easy to get started:
  - delete a couple packages I don't want from cd-1
  - add the couple I want from cd-2
  - cut a custom 1-cd distribution for internal use

>From what I've gathered, the basic process is to do
something like the following:

  1. copy the vanilla rh72 cd-1 to disk
  2. add/remove/change the rpms on it
  3. tweak the RedHat/base/comps file to match
  4. run genhdlist to update things
  5. run pkgorder
  6. run splitdistro to make the cd trees based on the order
  7. genhdlist again for each disk splitdistro created
  8. create the iso images
  9. go wild.

I did a minimal test, where I mounted the rh72 cd-1
as /mnt/cdrom, cd'd there, and did "cp -a . /rh72"
to try to slurp all the contents to spinning disk.

I changed nothing (no steps 2-3 above), and ran 'genhdlist'
but anaconda aborts complaining about a package.  I ran
check-repository.py (after commenting out the include
todo line) and it reports possible problems with the same package.

Note that if I run genhdlist against /mnt/cdrom it appears
to work (returns immediately saying nothing) and if I run
pkgorder against /mnt/cdrom it returns a good list.

How could a totally 'un'-modified rh72 disk1 that
was simply copied to spinning disk fail genhdlist ?

Am I missing something here ?

---------- vince skahan boeing com --------------
   Connexion by Boeing - Cabin Network

Kickstart-list mailing list
Kickstart-list redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]