[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Could not find CDROM.



Hi Theewara,
 
The following script puts the following kickstart files to the appropriate places in the first disc of RH 7.2.
 
Suppose directory "disc1" includes the contents of the 1'st disc and you would like to install the following files
in their appropriate places: ks.cfg, syslinux.cfg and optionally, your own modified customer.msg, instead of the
default boot.msg file.
 
 Note: syslinux.cfg includes ...ks=file:/ks.cfg... , instead of ks=cdrom:/ks.cfg (that worked fine in RH 6.2)
 
[1]. The update script:
 
#!/bin/sh
BASE=`pwd`
#
# mount cdboot.img
mount -o loop $BASE/disc1/dosutils/autoboot/cdboot.img /mnt/floppy

# decompress the memory filesystem on the floppy
gzip -dc /mnt/floppy/initrd.img > floppy.initrd

# create temporary directory
mkdir /tmp/redhat

# mount the compressed filesystem from the floppy
mount -o loop floppy.initrd /tmp/redhat

# install the ks.cfg file into the / directory on the memory filesystem
install -c -m 644 ks.cfg /tmp/redhat

# install the syslinux.cfg file into the memory filesystem on the floppy
install -c -m 644 syslinux.cfg /mnt/floppy
install -c -m 644 custom.msg /mnt/floppy

umount /tmp/redhat

gzip -9 floppy.initrd

\mv -f floppy.initrd.gz /mnt/floppy/initrd.img

umount -f /mnt/floppy

rmdir /tmp/redhat
 
[2]. syslinux.cfg (example)
 
default ks
prompt 1
timeout 600
display customer.msg
label ks
kernel vmlinuz
append ks=file:/ks.cfg initrd=initrd.img lang= devfs=nomount ramdisk_size=7168 vga=788
 
[3]. customer.msg (example)
 
Modify the provided boot.msg ....
 
 
[4]. ks.cfg (example)
#Generated by Kickstart Configurator lang en_US langsupport en_US keyboard us mouse generic3ps/2 timezone --utc Asia/Jerusalem rootpw comverse #reboot bootloader --useLilo --linear --location=mbr install <STRONG>cdrom</STRONG> clearpart --all part /boot --fstype ext3 --size 100 --ondisk sda part / --fstype ext3 --size 500 --ondisk sda part swap --size 1000 --ondisk sda part /var --fstype ext3 --size 500 --ondisk sda part /usr --fstype ext3 --size 3000 --ondisk sda part /opt --fstype ext3 --size 1000 --ondisk sda part /home --fstype ext3 --size 1000 --grow --ondisk sda auth --useshadow --enablemd5 firewall --medium --trust eth0 --ftp --telnet --ssh --smtp --dhcp --http xconfig --server "SVGA" --monitor "generic monitor" %packages @ Printing Support @ Classic X Window System @ X Window System @ GNOME @ Network Support @ Messaging and Web Tools @ NFS File Server @ Anonymous FTP Server @ Web Server @ Utilities @ Software Development @ Kernel Development balsa esound-devel rsync compat-libstdc++ mozilla-mail VFlib2-devel gaim glade libesmtp gnome-games ddd libgtop-devel libpcap gnome-pim-devel libghttp-devel gdk-pixbuf-devel fam-devel asp2php-gtk pan ORBit-devel libunicode-devel freetype-devel gnome-core-devel php-imap rhn_register-gnome kernel-smp lesstif-devel doxygen redhat-config-network libglade-devel apache-devel nmap-frontend htmlview oaf-devel up2date-gnome mozilla-psm GConf-devel ical licq libxml-devel gnome-games-devel bonobo-devel licq-gnome XFree86-devel exmh netscape-communicator vnc-server Xaw3d-devel librep-devel control-center-devel openssh-askpass-gnome XFree86-SVGA libungif-devel memprof vnc gcc-objc glib-devel Mesa-devel netpbm-devel xpdf XFree86-compat-modules imlib-devel ucd-snmp apacheconf libmng-devel openssh-askpass gnome-libs-devel audiofile-devel usbview netscape-common galeon gq gtk+-devel pdksh dialog %post echo "Kickstart-installed Red Hat Linux 2.4.7-10 `/bin/date`" > /etc/motd
I hope to your success. I used this method with no problems!
Avi Koski, Unix System Programmer
Comverse Ltd.
-----Original Message-----
From: Theewara Vorakosit [mailto:thvo ksc th com]
Sent: Thursday, May 02, 2002 4:34 PM
To: kickstart-list redhat com
Subject: Could not find CDROM.

Dear Sir,
    I modify redhat 7.2 distribution. I add my own packages. I put ks.cfg in first cdrom (bootable). I use image/boot.img as a boot image when I run mkisofs. This CD can boot. But it can not install when I use ks=cdrom:/ks.cfg when I boot it. The screen reports that "Can not find redhat cdrom...".  However, If I move use ks.cfg from floppy disk with this cdrom. It works fine. Would you please tell me how to solve these problems.
Thanks,
Theewara

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]