[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Kickstart-list digest, Vol 1 #829 - 6 msgs



I use the PXE server method (active not the passive pxelinux.cfg method) to
boot the nodes.  I currently use the ks:file=/tmp/ks.cfg method.  I place
the ks.cfg file into the loopback mounted image of linux.2 (which I believe
is the initrd.img file from the RH9 disk.  Is there someplace to change the
pointer to the ks file within the linux.1 (which I believe is the kernel
from the RH9 bootdisk).  I tried many solutions and I still have to manually
add the append= line when booting when the node contacts the PXE server.

The kickstart method that I used is pretty close to the method described in
the Jan/Feb 2003 issue of Linux Magazine by Forrest Hoffman.

Also I noticed that I have trouble finding the NFS directory where I have
the RH9 CDS on the first try.  By this I mean, I get the "cant find/connect
to the listed NFS server for the install" red/blue text screen.  The box
comes up to modify the NFS server location.  I simply click on Enter,
without changing my existing parameters, and the install proceeds without
user intervention and processes my ks file and my %post configuration.

Other than these two nagging issues, my nodes get installed with (almost) no
user intervention.

Oh, I have a problem with the %post section accepting my encrypted password
for regular user accounts.  I works fine on the root account.

Thanks for any help.

Bob
--__--__--

Message: 6
Date: Thu, 17 Jul 2003 09:02:56 +0800 (WST)
From: John <red computerdatasafe com au>
To: kickstart-list redhat com
Subject: Re: redhat 8 bootable kickstart trouble
Reply-To: kickstart-list redhat com

On Wed, 16 Jul 2003, Patrick Simon wrote:

> I have been searching around for a bit, and so far haven't found a
solution to this problem.
> 
> I am creating a custom install of Redhat 8, and now i need it to be
kickstarted as well. Where do i put the kickstart file so that the installer
recognizes it. I have tried to unzip and mount the initrd.img file under the
isolinux directory, and then installing the ks.cfg file under the tmp
directory of the initrd.img image. And changed the isolinux.cfg file to read
> 
> default ks
> prompt 0
> timeout 60
> display boot.msg
> F1 boot.msg
> F2 options.msg
> F3 general.msg
> F4 param.msg
> F5 rescue.msg
> F7 snake.msg
> label ks
>   kernel vmlinuz
>   append ks initrd=initrd.img lang= devfs=nomount ramdisk_size=9216
> 
> However, the install cannot find the ks.cfg file.
> The non-kickstart install works fine, so obviously this is where i am
screwing up.
> Am I way off base, or almost there?
> Any help would be appreciated.

Two things you must do:
1. Put the ks file somewhere. It can be on the media, it can be on a
separat floppy, it can be on a webserver some place.

2. Use "ks=" on the append line to specify where it is.

If you RTFM, you will find the details.



> 
> Patrick Simon
> 

-- 
Please, reply only to the list.

Join the "Linux Support by Small Businesses" list at
http://mail.computerdatasafe.com.au/mailman/listinfo/lssb





--__--__--

_______________________________________________
Kickstart-list mailing list
Kickstart-list redhat com
https://www.redhat.com/mailman/listinfo/kickstart-list


End of Kickstart-list Digest




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]