[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: tftp problem



Xavi,

try adding
  ksdevice=eth0
or equivalent to the kernel options list.

and..
> ..... in.tftpd[9095]: tftp: client does not accept options
this is normal.


Yours,
Daniel.

--------------------------------------------------------------
Dr. Dan Kidger, Quadrics Ltd.      daniel kidger quadrics com
One Bridewell St., Bristol, BS1 2AA, UK         0117 915 5505
----------------------- www.quadrics.com --------------------


> -----Original Message-----
> From: Xavier Fustero [mailto:xavi ebi ac uk]
> Sent: 23 October 2003 17:08
> To: kickstart-list redhat com
> Subject: tftp problem
> 
> 
> Hi,
> 
> I am trying to use kickstart on IBM e-servers (blades hs20, 
> type 8678) 
>  with GigaEthernet broadcom bcm5700. I readed all documentation to 
> install this with PXE-kickstart. Actually I started to play 
> on that but 
> I don't success. I got it working from a floppy but when I try to run 
> automatically on network it fails.
> 
> ** dhcp:  
> I have a dhcp server running on an alpha server. It works and provide 
> the ip to any of our machines.
> dhcp.conf for the blades:
> -----------------
> group {
>    use-host-decl-names on;
>    %%CLASS_ENTRY_BEGIN web-blades
>    host %HOSTNAME% {
>    hardware ethernet %HW-ADDRESS%;
>    fixed-address %HOSTNAME%;
>    next-server my_SERVER;
>    filename "pxelinux.0";
> 
> Actually, if I change the sort of the last two lines it 
> doesn't boot(?).
> 
> ** PXE
> /tftpboot:
> default.netboot-7.3  initrd.img    pxelinux.0  pxelinux.cfg  
> vmlinuz  X86PC
> 
> /tftpboot/pxelinux.cfg:
> CB1EG... (hexadec. link to default.netboot-7.3)   default    
> default.netboot-7.3
> 
> default.netboot-7.3 contains:
> label ks
>   kernel vmlinuz
>   append ksdevice=eth1 
> ks=nfs:my_nfs_server:/whatever/ip_number-kickstart initrd=initrd.img 
> lang= devfs=nomount ramdisk_size=8192
> 
> ** tftp:
> tftp-server-0.29-3
> server_args             = -s /tftpboot  
> or  
> server_args             = -c -s /tftpboot
> 
> ** ks.cfg
> ...
> url --url http://ftp.redhat.com/pub/redhat/linux/7.3/en/iso/i386
> ...
> 
> When I boot the blade, it gets the ip from my dhcp, the PXE message 
> appears on the screen and it starts to boot the vmlinuz and 
> the initr. 
> However, the ks doesn't seems to be read because it starts the 
> installation asking: Choose a language,...... so I have to 
> make all the 
> installation process manually.  I look on my 
> /var/log/messages from the 
> master machine (pxe, tftp and nfs server) and I got the 
> following message:
> 
> ..... in.tftpd[9095]: tftp: client does not accept options
> 
> Can someone help me on this issue?
> Thanks a lot,
> Xavi
> 
> 
> 
> -- 
> Xavier Fustero Benavent
> 
>   Work:+44(0)1223 494664     
>   Fax: +44(0)1223 494468
> 
> 
> 
> _______________________________________________
> Kickstart-list mailing list
> Kickstart-list redhat com
> https://www.redhat.com/mailman/listinfo/kickstart-list
> 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]