[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: python errors in pkgorder script



On Fri, 23 Jan 2004, Taylor, ForrestX wrote:

> On Fri, 2004-01-23 at 09:51, Andy Rabagliati wrote:
> > Folks,
> > 
> >   I am building a custom distro based on Fedora and my own rpms
> >   and a good selection from various repositories.
> > 
> >   This has worked fine before, but tidying things up and fleshing
> >   out my comps file I now get this error :-
> 
> Edit /usr/share/comps-extras/getfullcomps.py and change /RedHat to
> /Fedora.
> 
> Run getfullcomps.py:
> 
> /usr/share/comps-extras/getfullcomps.py /export i386 >/dev/null
> 
> That should tell you if you have dependencies or packages missing from
> your tree.
> 
> Forrest

Thanks very much - very helpful.

It also needed "comps.xml" as the first parameter.

It came up with the same error, but there is a debug print further up that
I could uncomment to track down the problem.

I have a sunclock_huge_earthmap-1.0-1.i386.rpm that has no requirements,
which causes these scripts to raise exceptions.

% rpm -q --queryformat '%{NAME}\t%{REQUIRENAME}\n' -qp /export/i386/Fedora/RPMS/sunclock*          
sunclock        libc.so.6(GLIBC_2.0)
sunclock_huge_earthmap  (none)
sunclock_jpeg_big_maps  rpmlib(PayloadFilesHavePrefix)

stderr from getfullcomps.py also pointed out some other unrelated
shortcomings in my comps file - thanks.

I had skipped using getfullcomps.py as fedora / rh9 build dependencies
on the fly - but the diagnostics are very informative.

Cheers,    Andy!




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]