[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: partition cciss/c0d0 using ks.cfg file with multiple cciss devices attached



Thanks Christian. Glad to hear its working for someone, hopefully I'm just doing something silly, but I can't seem to find it. I retried using the --initlabel option and I still get the same result. Not sure what my issue is. What version(s) of redat does the below work for in your experience? I'm trying to get it working with RH ES3 AS

Christian Rohrmeier SCHERING DE wrote:

Hello Reynold,

The following works for me, even on systems with 2 CPQRaid Controllers
(e.g. 5i with local disks plus 6400 with external SCSI Enclosure) and
various (CPQRaid-defined) locgical drives (e.g. c0d0, c0d1, c0d2,
c1d0,c1d2, etc.) "c0d0" is always the first logical disk on the first CPQ
RAID controller, and the rest go from there. Typical would be a DL380 with
4 local disks. These are setup as two RAID 1+0 mirrored drives (= 2 logical
drives.) Add to that a non-onboard RAID Controller (a CPQ 6400 say) with an
extneral enclosure and 12 drives, in a RAID 5 or RAID ADG setup.

The only thing I notice thats different from your script is that I use
"--initlabel" with clearpart, and that I use both "--drives=" and
"--ondisk=".

clearpart --drives=cciss/c0d0 --all --initlabel
part /boot --fstype ext3 --size 100 --asprimary --ondisk=cciss/c0d0
part swap --size 2000 --ondisk=cciss/c0d0
part / --fstype ext3 --size 8000 --ondisk=cciss/c0d0

Cheers,

Christian

_________________
Christian Rohrmeier
Schering AG
Corporate IT - Infrastructure and Services
Computer Systems and Operations
System Administration - Research and Development
Tel +49 30 468 15794
Fax +49 30 468 95794


Reynold L Demarco <reynold.demarco@ bms.com> To Sent by: kickstart-list redhat com kickstart-list-bo cc unces redhat com Subject partition cciss/c0d0 using ks.cfg 07.11.2005 16:06 file with multiple cciss devices attached Please respond to Discussion list about Kickstart <kickstart-list r edhat.com>



Has anyone had luck auto-partitioning a cciss/c0d0 device using a ks.cfg
file and the ondisk parameter when there are multiple cciss devices on the
system?  Below is the snippet of my ks.cfg file I am using to try and
accomplish this.  Using the below snippet, if I leave off the ondisk
parameters, it all works, but spreads my filesystems across multiple disks
on the system, which is not what I want.  I want to force it to the
internal cciss/c0d0 disk only.  When I leave it this way, it retrieves the
base.img files, parses my config file, then gives me the error: "Could not
allocate the requested partitions:  Partitioning failed: Could not allocate
partitions."
clearpart --drives cciss/c0d0 --all
part /boot --fstype ext3 --size 512 --ondisk cciss/c0d0
part / --fstype ext3 --size 14000 --ondisk cciss/c0d0
part /var --fstype ext3 --size 10000 --ondisk cciss/c0d0
part /tmp --fstype ext3 --size 2000 --ondisk cciss/c0d0
part swap  --size 2048 --ondisk cciss/c0d0

If the cciss/c0d0 partition table is cleared, I do have enough room on the
disk for the above partitions.  I've tried the above with and without the
"=" as well.  I've also tried leaving out the clearpart and starting with a
blank disk.  And I can use the same exact snippet above except I replace
the cciss/c0d0 with the appropriate sda or hda on a system with hd or sd
drives and it works just fine when there are multiple hd or sd drives
attached.
Any help appreciated.  Thanks.
_______________________________________________
Kickstart-list mailing list
Kickstart-list redhat com
https://www.redhat.com/mailman/listinfo/kickstart-list


_______________________________________________
Kickstart-list mailing list
Kickstart-list redhat com
https://www.redhat.com/mailman/listinfo/kickstart-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]