[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Grub not getting installed after kickstart installation



Hi,

On 10/4/05, Stuart J. Browne <sjbrowne bluebottle com> wrote:
Ajitabh,

In your %post section, you have these two lines:
# /bin/echo -e "root (hd0,0) \n install /grub/stage1 d (hd0) /grub/stage2 p
\
  (hd0,0)/grub/grub.conf \n quit" | /sbin/grub --batch

You've only commented out the first part of it, not the second.  It'd come up with an error 'command not found: hd0,0', or some such.

Yeah, I realised that after I posted to the list. I had removed those lines entirely in my next attempt. My point was first there should not be a need of installing grub (am I really correct in this ??) through post install section. Second even if I am installing it using the grub --batch command (lines prior to the one you pointed out), why is it still not working.

Comment out that 2nd line, and try it again.

Tried and still the same results.

Now, as for 'ls', 'mv' etc. not being mounted when you chroot in emergency mode, is somewhat odd.  Are you sure it's not just that /bin/ isn't in the emergency sesions path?  You've actually looked in /bin, not found them, double checked to ensure that the 'cureutils' package is installed?

I am sure that the coreutils package is installed as there is no error while installing it. I checked for the presence of these commands when I chrooted to /mnt/sysimage and then tried to run grub-install. All i got from grub-install was - "could not find rm....." Then I came out of chroot and using the ls from the cd checked for the presentce of crusial core--utils files in /mnt/sysimage/bin and couldn't find them.
--
Regards.
Ajitabh Pandey
http://www.ajitabhpandey.info/
ICQ - 150615062
Registered Linux User - 240748
GnuPG Key ID - 35CF8CC4
Key fingerprint = E1A8 657D BE0C 4747 52EC  10C4 1AC2 C124 35CF 8CC4

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]