[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mount cdrom in %post on 2.6 kernel

On Mon, 12 Sep 2005, Robert Wehner wrote:

I am migrating some kickstarts from RHEL 3.0 to RHEL 4.0 and I can't figure
out how to get the cdrom device mounted in the %post section. In RHEL 3.0, I
always used the method mentioned on this list many times:
mount /mnt/cdrom
tar xfp /mnt/cdrom/somefile.tar -C /opt

That doesn't work in RHEL 4.0 as updfstab is now gone. It looks like in RHEL
4 it is the the haldaemon (by calling fstab-sync) that does something
similar to what updfstab used to do. I tried starting that in %post, and it
says it started OK but it doesn't update fstab, nor does it stay running.

I've also tried parsing /proc/sys/dev/cdrom/info and then attempting to
mount the device listed there. That didn't work as the device hasn't been
made yet at /dev/hd?.

Anyone have any ideas on how to get the CD mounted during %post in RHEL 4

Run '/sbin/udevstart' at beginning of %post which will create the necessary devices, worked for me at least.

	- Panu -

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]