[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: logvol --noformat on FC5



On Mon, Apr 17, 2006 at 12:43:12AM +0200, Axel Thimm wrote:
> On Fri, Apr 14, 2006 at 01:59:31PM +0200, Axel Thimm wrote:
> > I'm trying to setup a kickstart file to reinstall FC5 on a hard disk
> > while keeping a data partition intact. The data partition is in fact a
> > logical volume to allow me to reshuffle PEs if neccessary.
> > 
> > If I look at the anaconda.cfg that is created when I enter the setup
> > manually in anaconda I see the following directives:
> > 
> > #part /boot --fstype ext3 --onpart sda1
> > #part pv.2 --noformat --onpart sda2
> > #volgroup systemoctopus --pesize=32768 pv.2
> > #logvol /srv/atrpms.net/storage/octopus --noformat --fstype ext3 --name=data --vgname=systemoctopus --size=222272
> > #logvol / --fstype ext3 --name=root --vgname=systemoctopus --size=14976
> > #logvol swap --fstype swap --name=swap --vgname=systemoctopus --size=1984
> > 
> > But if I try to use them to automate the process the install results
> > in
> > 
> > | Error mounting device systemoctopus/data as
> > | /srv/atrpms.net/storage/octopus: No such file or directory
> > | 
> > | This most likely meas this partition has not been formated.
> > | 
> > | Press OK to reboot your system.
> 
> BTW: Even though there is this error message the data partition that
> was to be --noformat'ed is lost. Looks like anaconda wipes the whole
> volume group.

Looks like the bug is in missing --noformat on the volgroup
declaration as well as missing --useexisting on the logvol lines w/o
the --noformat. E.g. the bug is in the creation of the anaconda.cfg
file, not in the parsing.

I'll file a bug as soon as bugzilla is up again.
-- 
Axel.Thimm at ATrpms.net

Attachment: pgpyLNzECwwIU.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]