[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora and kickstart



seth vidal wrote:
On Tue, 2007-04-10 at 10:30 -0400, Brian Peront wrote:
Seth,

On my system in

/free/FC6/Fedora/RPMS

I ran createrepo -v . ( In /free/FC6/Fedora/RPMS ) and my rpms are there. I'm still getting the same error missing package.

run it in FC6, not in Fedora/RPMS

and you need to run:
createrepo -g relative-path-to-comps.xml .

-sv
My experience with RHEL5 which is similar to FC6 is as follows:

I have my unpacked CD's on an nfs server and then created a directory for my custom rpms. I ran createrepo on my custom rpm folder and added a "repo" lin to my kickstart file to include the customs rpms. I then add the custom rpm name to the packages section to install it.

The repo line should work well with http repositories. for my NFS stuff, I had to mount the nfs server in %pre to get the repo to work, but that's only for NFS.

I haven't needed to much with comps.xml to add my custom rpms.

Sincerely,
Jason


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]