[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RHEL5 Ejecting CD Before %post

Jason Edgecombe wrote:
Goetz Rieger wrote:
Hi there,

I'm building a completely CD/DVD based RHEL5 kickstart install. I've to integrate additional stuff like JBoss and Raid utilities. I have tried the same way I've done it a lot of times with RHEL4 by mounting and accessing the CD/DVD in the %post stage.

Apart from the /tmp/cdrom device file disappearing after the packages are installed (does make mounting the CD not easier) it looks like the CD is ejected before the post scripts are run. To verify I did a:

echo "Sleeping in %post..." > /tmp/anaconda_dbg.log
sleep 180
%post --nochroot
echo "Sleeping in %post --nochroot..." >> /mnt/sysimage/tmp/anaconda_dbg.log
sleep 180

The CD is clearly ejected before %post is done. So remounting to get to my custom files is out of question. Am I overlooking something obvious or is there a way to prevent this behaviour?

eject -t /dev/device will retract an open motorized cdrom tray.
It's a recent IBM xSeries which, like most servers I've worked on in the last years, comes with a laptop-style cdrom. So no option...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]