[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Automatically using the right kmdl module with the newest kernel



Hi,

I'm doing kickstarts in RHEL5. I have extra repo statements in the kickstart file that point to an updates repo which has RedHat updates including the kernel. I also have a repo with extras like the openafs rpms from atrpms.net.

How can I have the install automatically pick the right openafs-kmdl rpm to go with the kernel. Yum can do it if I use the yum-plugin-kdml rpm. Is there any way to activate yum-plugin-kmdl during the install or some other way to pick the right kdml to go with the latest kernel. I would prefer to now have to hard-code the kmdl rpm version in the kickstart file.

What are my options besides hard-coding the kmdl rpm version or running yum in %post?

Thanks,
Jason


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]