[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: "pump" times out -- extend a few seconds more?



> (So typically when an issue is solved, does the person with the issue and resolution write a summary for the list?)
 
Usually all I see is either a "it worked" or those with problems stop asking questions :(
 
If you ever want to make a "generic" boot cd, you can assign the IP address on the boot: line, then have just what you need to get the machine up in the embedded ks.cfg, and use wget, or nfs (not sure about ftp/tftp) to pull in the system specific config, then use %include to add it into the ks.cfg.  This is the way we are moving to.
 
Glad you got things working,
 
Chip


From: kickstart-list-bounces redhat com [mailto:kickstart-list-bounces redhat com] On Behalf Of Ramthun, William
Sent: Tuesday, March 06, 2007 4:01 PM
To: Discussion list about Kickstart
Subject: RE: "pump" times out -- extend a few seconds more?

Chip,

 

Thanks for the help!

 

I did try setting ethtool_opts=”autoneg off speed 100 duplex full” along with the nicdelay=50 earlier and received no love for my efforts.

 

I did build the 20 configs and wrapped them in the initrd.img – and that worked.  I did have to edit all 20 configs for a cut/paste line-wrap error.  But now the 20 systems are built.

 

I really appreciate the help in working to a solution.  Since this problem is solved for now and for all my other installation needs the ks=http:// works, I am not sure that I will ever learn what my network problem was.

 

(So typically when an issue is solved, does the person with the issue and resolution write a summary for the list?)

 

Regards,

-Bill

 


From: kickstart-list-bounces redhat com [mailto:kickstart-list-bounces redhat com] On Behalf Of Shabazian, Chip
Sent: Monday, March 05, 2007 12:59 PM
To: Discussion list about Kickstart
Subject: RE: "pump" times out -- extend a few seconds more?

 

Try the following:

 

If you are connected to a gigabit switch:

 

Boot: ap10903-02-net ksdevice=eth0 ip=10.196.254.122 netmask=255.255.255.0 gateway=10.196.254.1 nicdelay=50 linksleep=50 ETHTOOL_OPTS="autoneg on speed 1000 duplex full"

 

If you are connected to a 100Mb switch:

 

Boot: ap10903-02-net ksdevice=eth0 ip=10.196.254.122 netmask=255.255.255.0 gateway=10.196.254.1 nicdelay=50 linksleep=50 ETHTOOL_OPTS="autoneg off speed 100 duplex full"

 

 

 


From: kickstart-list-bounces redhat com [mailto:kickstart-list-bounces redhat com] On Behalf Of Ramthun, William
Sent: Monday, March 05, 2007 8:51 AM
To: Discussion list about Kickstart
Subject: RE: "pump" times out -- extend a few seconds more?

 

Summarizing my situation:

 

  Client HW:       HP DL385

  Client OS:       RHEL3U5

  The boot cd is mounted via the virtual cdrom thru HP’s ILO port.

 

My isolinux.cfg contains the entry:

 

  label ap10903-02-net

  kernel vmlinuz

  append ks=http://10.1.181.252/cgi-bin/avamar/dl385_data_node initrd=initrd.img text

 

And on the boot: line I use:

 

Boot: ap10903-02-net ksdevice=eth0 ip=10.196.254.122 netmask=255.255.255.0 gateway=10.196.254.1  <nicdelay/linksleep=options>

 

            I’ve used both nicdelay and linksleep with values of 50, 500, 5000, and 50000 with no discernable boot delays.

 

The result is:

I see vmliniz and initrd loading.

I am presented the “welcome to red hat linux” blue screen (I’m in text mode)

          Then I see the usb and raid controller drivers load

          Then I see a “determine hostname and domain”

          ( I think this is where the timeout occurs )

          Then I am prompted to “choose a language”

 

In a different terminal window I am “pinging” the 10.196.154.122 IP during the whole boot process.  Once the “choose a language” prompt appears, then the interface begins responding to my pings.

 

My next step is to include the Kickstart config in the initrd.

 

If anyone sees any issues with my method, please drop me a note.

Thanks

-Bill

 

 

 

 

 


From: kickstart-list-bounces redhat com [mailto:kickstart-list-bounces redhat com] On Behalf Of Vivek Kalia Euroclear com
Sent: Friday, March 02, 2007 10:49 AM
To: kickstart-list redhat com
Subject: RE: "pump" times out -- extend a few seconds more?

 


Regarding experience of parameters
                 nicdelay=50 linksleep=50
I used them today to circumvent the Anaconda "time-out" and can confirm that they worked in the required manner.
My previous http builds were failing to contact the apache server due to the time-out. With these values in place, I could see Anaconda waiting about 50 seconds while the NIC initialised; the build then completed normally.

I am still investigating the root cause of the time-out, but this seems a good circumvention.

Vivek Kalia

This e-mail message, including any attachments transmitted with it, is CONFIDENTIAL and may contain legally privileged information.This message is intended solely for the use of the individual or entity to whom it is addressed. If you are not the intended recipient you should not read, copy, distribute, disclose or otherwise use this information. If you have received this message in error, please notify us immediately and delete it from your system. The integrity and security of this message cannot be guaranteed and it may be subject to data corruption and unauthorised amendment, for which we accept no liability.
Euroclear reserves the right to retain email messages on its systems and to the extent and under circumstances permitted by applicable law, to monitor and intercept email messages to and from its systems. Euroclear is the marketing name for the Euroclear System, Euroclear plc, Euroclear SA/NV and their affiliates. http://www.euroclear.com

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]