[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kickstarting an RX4640 Itanium



Worked like a Champ! Thanks Bryan. Looks like my problem was not
having the "--size=" included in the /boot/efi line.

I knew it had to be something fairly simply, since I wasn't able to
find anyone on the net that was having much trouble at all
Kickstarting Itanium hardware.

Thanks again!

On 3/28/07, Bryan Stillwell <bryan stillwell hp com> wrote:
Matt,

Here's a kickstart script that I just tested with a network kickstart
and it worked fine on an rx2660.

Bryan

Matt P wrote:
> Yes, you're correct, I've got Itatium on the brain, there are only 2
> internal drives. I'm in the process of building out 70+ machine which
> are a mix of Itanium (RX4640) and x86 (DL class). The x86 machines
> have 4 HDDs, my mistake.
>
> I'm pretty sure the Module gets loaded. I didn't use lsmod but fdisk
> does see the disk and the partitions that HP SmartStart builds which
> includes efi.... I'll give that "device scsi cciss" a shot. the worst
> part about testing this is I've got to burn a new DVD each time I make
> a change to the config. Then sneaker net it over to the customer site,
> etc, etc... It's a royal pain.
>
>
> On 3/28/07, Bryan Stillwell <bryan stillwell hp com> wrote:
>> Matt,
>>
>> I work in HP's Open Source and Linux Organization and I've done multiple
>> kickstart installs on Itanium hardware and everything looks right to me.
>>   It sounds like the cciss driver isn't being loaded during your
>> kickstart install for some reason.  Can you switch to the shell (Alt-F2)
>> and run lsmod (or 'cat /proc/modules') and see if the cciss driver is
>> loaded when you receive that message?
>>
>> You can also try adding the following line to the top of your kickstart
>> script to make sure the cciss driver is loaded:
>>
>> device scsi cciss
>>
>> BTW, how did you manage to fit four internal drives in an rx4640?
>> There's only room for two.
>>
>> Bryan

install
nfs --server=test.test --dir=/dist/redhat/rhel4/as/U3/ia64
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp
rootpw --iscrypted XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
firewall --disabled
selinux --disabled
authconfig --enableshadow --enablemd5
timezone --utc America/Denver
bootloader --location=mbr --append="console=ttyS0"
clearpart --all --initlabel=gpt
part /boot/efi --fstype vfat --size=100 --ondisk=cciss/c1d0
part swap --fstype swap --size=2048 --ondisk=cciss/c1d0
part / --fstype ext3 --size=256 --grow --ondisk=cciss/c1d0

%packages
e2fsprogs
kernel
dosfstools
elilo

%post

_______________________________________________
Kickstart-list mailing list
Kickstart-list redhat com
https://www.redhat.com/mailman/listinfo/kickstart-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]