[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [PATCH] Add --root-device to upgrade command



> See F9_Autopart vs. FC3_Autopart. Same case as with upgrades. The base 
> class doesn't define _getParser and the derived class calls 
> KSOptionParser directly instead of calling _getParser from the base 
> class. This will break when the base class doesn't define _getParser.

Oh yes of course.

Then in that case, it looks fine to me.  Once someone comments on the
anaconda portion (which could also be me here in a minute), I'll commit
to pykickstart.  Thanks for the patch.

- Chris


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]