[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Old style fixed partitions in KS-- Anaconda bug??



I'm trying to lay out disk partitions in a certain way-- 
This has worked for years, but recently broke due either to
a change in the way Kickstart works or a bug in Anaconda.

I use sfdisk to lay out the drive in the %pre section:

%pre

sfdisk -uM /dev/sda <<EOF
,150,L
,,E
;
;
,512,L
,2048,S
,6000,L
,2048,L
,10000,L
,,L
EOF

(this works correctly)

If I specify what goes where in the KS file:

part /boot --fstype ext3 --onpart sda1
part /tmp --fstype ext3 --onpart sda9
part /var --fstype ext3 --onpart sda8
part swap --onpart sda6
part /local1 --fstype ext3 --onpart sda10
part /usr --fstype ext3 --onpart sda7
part / --fstype ext3 --onpart sda5

Anaconda croaks with the following error:

15:27:41 CRITICAL: parted exception: Error: Error informing the kernel 
about modifications to partition /dev/sda5 -- Device or resource busy.  
This means Linux won't know about any changes you made to /dev/sda5 until 
you reboot -- so you shouldn't mount it or use it in any way before rebooting.


Googling this error shows it popping up at various time (back to FC3 or
so), but no solutions.

This worked fine in CentOS 4.4 (RHEL4 u4), but broke in the next update
(and is still broken in CentOS 5.1 [RHEL5 u1]).

I could work around this in CentOS 4 by loading systems against an old 
4.4 image, then applying all the updates to get to 4.6. I can't do this in
5, since it is broken for all releases...

Is there better way to achieve what I'm doing or is this just 
an Anaconda bug that's making my life difficult? I don't see an advantage
to moving everything to LVM for simple single-disk systems...


Thanks--

--- Cris

PS: I have a couple Anaconda dumps if someone is interested... 

-- 
 Cristopher J. Rhea                     
 Mayo Clinic - Research Computing Facility
 200 First St SW, Rochester, MN 55905
 crhea Mayo EDU
 (507) 284-0587


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]