[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Install that previously worked now failing



Robert Lazzurs wrote:
On Wed, Oct 15, 2008 at 16:15, Robert Lazzurs <rob lazzurs net> wrote:
On Wed, Oct 15, 2008 at 15:57, Michael DeHaan <mdehaan redhat com> wrote:
Robert Lazzurs wrote:
Hello, of course, it is an attachment to this email.

Thanks again.

On Tue, Oct 14, 2008 at 16:59, Pablo Iranzo Gómez <piranzo redhat com>
wrote:

Can you post your cobbler rendered kickstart to have a look on it?

Regards
Pablo


----- "Robert Lazzurs" <rob lazzurs net> escribió:


On Tue, Oct 14, 2008 at 16:51, Robert Lazzurs <rob lazzurs net>
wrote:

Hello,

I have an install here that I did have previously working with this
hardware and mirror setup however that is now failing for some

unknown

reason.  Below is the trace I got back from anaconda, if anyone has
any ideas please let me know :)

15:01:55 INFO    : Running kickstart %%traceback script(s)
15:01:55 INFO    : All kickstart %%traceback script(s) have been

run

15:01:55 CRITICAL: Traceback (most recent call first):
 File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35,

in

comparePoEVR
  (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
 File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191,

in __eq__

  if comparePoEVR(self, other) == 0 and self.arch == other.arch

and

self.name == other.name:
 File "/usr/lib/yum-plugins/fedorakmod.py", line 151, in

resolveVersions

  elif sameName == None:
 File "/usr/lib/yum-plugins/fedorakmod.py", line 222, in

installAllKmods

  rAvaModules = resolveVersions(avaModules)
 File "/usr/lib/yum-plugins/fedorakmod.py", line 276, in

postresolve_hook

  newKernels + installedKernels)
 File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 153,

in run

  func(conduitcls(self, self.base, conf, **kwargs))
 File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 442,
in buildTransaction
  self.plugins.run('postresolve', rescode=rescode,

restring=restring)

 File "/usr/lib/anaconda/yuminstall.py", line 1267, in

doPostSelection

  (code, msgs) = self.ayum.buildTransaction()
 File "/usr/lib/anaconda/backend.py", line 177, in doPostSelection
  return anaconda.backend.doPostSelection(anaconda)
 File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
  rc = stepFunc(self.anaconda)
 File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 223, in currentStep
  self.gotoNext()
 File "/usr/lib/anaconda/text.py", line 539, in run
  (step, instance) = anaconda.dispatch.currentStep()
 File "/usr/bin/anaconda", line 982, in ?
  anaconda.intf.run(anaconda)
AttributeError: 'NoneType' object has no attribute 'epoch'


Thanks again :)

Sorry for replying to my own post however I figured that I should
include more information

This is an install with a fairly standard kickstart file (that has
not
changed) being generated from Cobbler.  Cobbler has just had the RHEL
5.1 dvd reimported into it and this kickstart template tested with
the
new import and this also fails, where it had previously worked

The install is on to a Dell PowerEdge 1950 III.

If anyone requires any more information about this please let me
know,
if I find a solution I will post back to the list.

Take care.
Cobbler runs through a copy of the DVD tree and identifies the varies
"split" repos and runs createrepo on them.

Having duplicates in the file shouldn't itself be a problem for yum, the
theory was that createrepo might have munged the repo, but seeing this was
an Anaconda traceback I was hoping someone might have better insight as to
how a "None" could get in there.
Hello everyone,

As discussed with Michael on IRC we have found the issue to be with
the duplicate repo lines.  My kickstart template for cobbler currently
has the following line

<cut>

Hello,

Michael has confirmed that this is caused by a bug in cobbler that
will be fixed soon.  Anyone who is having this issue should watch the
cobbler mailing list for a patch coming soon.

Take care.

_______________________________________________
Kickstart-list mailing list
Kickstart-list redhat com
https://www.redhat.com/mailman/listinfo/kickstart-list

Right, the theory is that multiple repo definitions to the same URL /do/ break Anaconda in certain situations, so we're going to add some basic checks to make sure that doesn't happen.

--Michael




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]