[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: cmdline ignored



On Tue, 28 Oct 2008, Phillip Groven wrote:

I tried this but it the kickstart still comes up with a text-GUI page to configure the drives

I am not sure why

What information did you get at your /tmp/part-include (or your file name), as well as anaconda.log ?

Regards
Pablo




-----Original Message-----
From: Pablo Iranzo Gmez [mailto:Pablo Iranzo redhat com]
Sent: Tuesday, October 28, 2008 12:19 AM
To: Discussion list about Kickstart
Subject: Re: cmdline ignored



     Try with something like:

%pre

set $(list-harddrives)

let numd=$#/2 # harddrive number

d1=$1 # 1st device

S1=$2 # 1st device size and so on



DISCO=$d1



echo "clearpart --drives=$DISCO --all --initlabel" >> /tmp/part-include

echo "part /boot --fstype ext3 --size=100 --ondisk=$DISCO" >> /tmp/part-include

echo "part pv.100000 --size=1 --grow --ondisk=$DISCO" >>  /tmp/part-include

echo "volgroup VG --pesize=32768 pv.100000" >> /tmp/part-include

echo "logvol swap --fstype swap --name=Swap --vgname=VG --size=2047" >> /tmp/part-include

echo "logvol  / --fstype ext3 --name=root --vgname=VG --size=1024" >> /tmp/part-include

echo "logvol /home --fstype ext3 --size=1024 --name=home --vgname=VG" >> /tmp/part-include

echo "logvol /tmp --fstype ext3 --size=1024 --name=tmp --vgname=VG" >> /tmp/part-include

echo "logvol /usr --fstype ext3 --size=3000 --name=usr --vgname=VG" >> /tmp/part-include

echo "logvol /opt --fstype ext3 --size=12000 --name=opt --vgname=VG" >> /tmp/part-include

echo "part /opt/iso --fstype vfat --size=8000 --ondisk=$DISCO" >> /tmp/part-include





     Regards

     Pablo









El lun, 27-10-2008 a las 17:42 -0700, Phillip Groven escribi:

I am trying to kickstart redhat  5.2 64 bit



We have used this %pre script for years and had have no issues.



I am trying to kickstart an HP DL365 G5 but does not like this script



The kickstart machine is running Redhat 4.5



This %pre script worked fine on a G4 with red hat 5.1.



The kickstart always comes up with a GUI to partition the drives



%pre

NEWDEV=`sed 's/.*rootdev=\([^ $]*\).*/\1/' < /proc/cmdline`

echo "##"

echo "## newdev = $NEWDEV"



if test "$NEWDEV" = "cciss" ; then

        DEVICE1="--ondisk cciss/c0d0"

elif test "$NEWDEV" = "ida" ; then

        DEVICE1="--ondisk ida/c0d0"

elif test "$NEWDEV" = "hd"  ; then

        DEVICE1="--ondisk hda"

elif test "$NEWDEV" = "sd"  ; then

        DEVICE1="--ondisk sda"

else

        DEVICE1=""

fi

echo "## kickstart configured with $DEVICE1"



cat > /tmp/parts.ks <<EOPARTS

clearpart --all --initlabel

part /boot --fstype "ext3" --size=128 --asprimary $DEVICE1

part swap --size=2048 $DEVICE1

part / --fstype "ext3" --size=512 --grow --asprimary $DEVICE1



EOPARTS







I have tried this fix but it did not resolve the issue



http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=1121516&prodTypeId=15351&prodSeriesId=1121516&objectID=c01430330





























_______________________________________________

Kickstart-list mailing list

Kickstart-list redhat com

https://www.redhat.com/mailman/listinfo/kickstart-list





--
Pablo Iranzo Gómez
(http://Alufis35.uv.es/~iranzo/)
(PGPKey Available on http://www.uv.es/~iranzop/PGPKey.pgp)
                  --
Postulado de Boling sobre la Ley de Murphy:

Si se encuentra bien, no se preocupe. Se le pasará

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]