[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Issue using --percent with "logvol" in RHEL 6 kickstart file



Jeff Wells wrote:
> I have tried adding the --size and --grow based on the the RHEL 6
> documentation but still get the same error:
> 
> part /boot --fstype "ext3" --size=250 --asprimary
> part pv.01   --size=1 --grow --ondisk=sda
> volgroup vglocal00 pv.01
> logvol swap     --fstype swap --name=swap00 --vgname=vglocal00 --
> size=2048
> logvol /tmp     --vgname=vglocal00 --size=2048 --name=tmp00
> logvol /var/log    --vgname=vglocal00 --fstype ext4 --size=1 --
> name=log00 --grow --percent=10
> logvol /        --vgname=vglocal00 --fstype ext4 --size=1 --name=root00
> --grow --percent=90
> 
> On Jun 14, 2011, at 2:17 PM, Jeff Wells wrote:
> > Issue:
> > When kicking with percent-based partitions, the logical volume
> creation errors.
> > logvol / --vgname=myvg --size=1 --name=rootvol --grow --percent=90
> >
> > Error:
> > An error was encountered while activating your storage configuration
> > lvcreate failed for vglocal00/log00: 11:30:57,333 ERROR: Unable to
> create new logical volume with no extents

How big is the disk you are installing to?  What happens if you calculate
the 10 and 90 percent yourself and put those numbers in the --size parameter
instead of using --percent?  Round your 10% up to the nearest extent-sized
boundary. Work out the numbers for the smallest disk it is likely to
encounter, and use --grow if it needs to be able to handle larger disks too.

I found in RHEL 5 that kickstart's LV calculations would sometimes round a
size down to 0 if I wasn't dividing the disk using exact extent-sized
proportions.


Moray.
"To err is human; to purr, feline."





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]