[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Driver disk loading via NFS fails on Cisco switch, OK on Dell

david klein <root nachtmaus us> wrote:

>Check to see if the client, switch and up-stream router agree on maximum
>frame-size (i.e. if one is trying to do jumbo-frames and the other can't,
>it can cause troubles). Make sure the switch-port that the client is using
>is setup as an access-port, not a trunk. Set the client's port for
>spanning-tree portfast and turn on BPDU-guard.

Thank you for the response.  Had already tried spanning-tree portfast
before turning off spanning-tree entirely, no difference.  I will look
into the other things you mention.

Updated observations:

- Problem happens exactly the same with a switch at the opposite
  end of the complexity spectrum - Netgear 5 port 10/100Mbps
  Switch FS605 v3.

- I noticed that on the good switch, you see two eth0 dialogs
  flash up before it proceeds; on a bad switch, only see one eth0
  dialog then the empty blue screen.

- If while it's in the failure state with the empty blue screen,
  I move the target's network connection to the good switch, it
  immediately takes off and continues the kickstart process

>On Sun, Nov 13, 2011 at 1:53 PM, whitivery <co55-sy1t dea spamcon org>wrote:
>> I have a working Cobbler server, using it to load units with
>> CentOS 5.7.  It works fine with a simple Dell 2716 switch
>> connecting the server and targets.  Also with a LinkSys RV016.
>> Substituting a Cisco 2960 switch, it fails.  It network boots,
>> shows the PXE menu, I choose an entry, it gets a DHCP address on
>> its eth0, and starts loading including getting its kickstart via
>> HTTP.  But when it goes to load the driver disk image via NFS, it
>> hangs.  The Anaconda Alt-F4 screen shows it not seeing the NFS
>> server; after 2 minutes of trying, it times out and the Alt-F4
>> screen shows an error dump.
>> Tried the switch with and without RST (rapid spanning tree)
>> active, no difference.
>> The switch seems to work OK for normal network operations outside
>> the kickstart environment, for what we use.
>> Any idea what it might be that could be interfering with the NFS
>> disk driver loading step?
>> _______________________________________________
>> Kickstart-list mailing list
>> Kickstart-list redhat com
>> https://www.redhat.com/mailman/listinfo/kickstart-list

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]