[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] P2Vs seem to require a very robust Ethernet

There's something ugly going on with the network.  Take a look at this experiment. I have a bunch of unused local disk space on my thing2 host and I wondered what would happen if I tried copying that large VM disk image from that RHEV Export NFS server to a local disk by hand?  So I tried it - see below and then some comments after that.


[root thing2 4c352001-ca40-418b-90be-4019f0f6a9e8]#
[root thing2 4c352001-ca40-418b-90be-4019f0f6a9e8]# pwd
[root thing2 4c352001-ca40-418b-90be-4019f0f6a9e8]# ls -al
total 78125020
drwxr-xr-x 2 vdsm kvm        4096 Dec  6 04:32 .
drwxrwx--- 3 vdsm kvm        4096 Dec  6 04:34 ..
-rw-r--r-- 1 vdsm kvm 80000000000 Dec  6 04:34 e8d37427-3bbc-46bd-80c5-c69e7c577c27
-rw-r--r-- 1 vdsm kvm         331 Dec  6 04:32 e8d37427-3bbc-46bd-80c5-c69e7c577c27.meta
[root thing2 4c352001-ca40-418b-90be-4019f0f6a9e8]# ls /data/greg
[root thing2 4c352001-ca40-418b-90be-4019f0f6a9e8]# cp e8d37427-3bbc-46bd-80c5-c69e7c577c27 /data/greg


And my window I pasted in above doing the copying is hung.  Looking in other windows, it copied about 204 MB to my local /data/greg directory before hanging.  Ctrl/C doesn't work, it's just hung.  After a couple minutes, it finally responded to my CTRL/C.  From another window, trying:

brctl show

also hangs. After several minutes, it comes back to a shell after CTRL/C, but never shows me any brctl output.  

Go figure.

Been a long night.  I'm going to grab some sleep.

- Greg

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]