[Libguestfs] Hivex bug? Cannot access Windows 2003 x64 Software\Classes key

Michael Huang Michael.Huang at visionsolutions.com
Fri Jun 24 20:15:37 UTC 2011

I tried both hivex-1.2.5 and hivex-1.2.7, same result. The same software hive can be loaded using Windows regedit tool, and had no problem to access the "Classes" key.
The other keys under Software (like Microsoft,  Wow6432Node, etc.) are OK.

Here is the hivexsh output with HIVEX_DEBUG=1 enabled:
hivex_open: successfully read Windows Registry hive file:
  pages:          5779 [sml: 4096, lge: 16384]
  blocks:         461619 [sml: 8, avg: 51, lge: 13752]
  blocks used:    456044
  bytes used:     23608640

Welcome to hivexsh, the hivex interactive shell for examining
Windows Registry binary hive files.

Type: 'help' for help summary
      'quit' to quit the shell

Software\> cd Classes
hivex_node_children: nr_subkeys_in_nk = 13, nr_subkeys_in_lf = 13
Software\Classes> ls
get_children: returning ENOTSUP because ri-record offset does not point to lf/lh (0x49020)
ls: Operation not supported

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libguestfs/attachments/20110624/487be4c9/attachment.htm>

More information about the Libguestfs mailing list