[Libguestfs] Hivex bug? Cannot access Windows 2003 x64 Software\Classes key

Michael Huang Michael.Huang at visionsolutions.com
Mon Jun 27 14:53:05 UTC 2011

Thanks Rich. Please see the Software hive attached. 

-----Original Message-----
From: Richard W.M. Jones [mailto:rjones at redhat.com] 
Sent: Friday, June 24, 2011 6:06 PM
To: Michael Huang
Cc: libguestfs at redhat.com
Subject: Re: [Libguestfs] Hivex bug? Cannot access Windows 2003 x64 Software\Classes key

On Fri, Jun 24, 2011 at 08:15:37PM +0000, Michael Huang wrote:
> I tried both hivex-1.2.5 and hivex-1.2.7, same result. The same software hive can be loaded using Windows regedit tool, and had no problem to access the "Classes" key.
> The other keys under Software (like Microsoft,  Wow6432Node, etc.) are OK.
> Software\Classes> ls
> get_children: returning ENOTSUP because ri-record offset does not point to lf/lh (0x49020)
> ls: Operation not supported

It certainly looks like a bug.  Is there any way you could share this
hive with us / just me?


Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
virt-top is 'top' for virtual machines.  Tiny program with many
powerful monitoring features, net stats, disk stats, logging, etc.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Software.zip
Type: application/x-zip-compressed
Size: 5131751 bytes
Desc: Software.zip
URL: <http://listman.redhat.com/archives/libguestfs/attachments/20110627/11532a70/attachment.bin>

More information about the Libguestfs mailing list