[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] Trying to use virt-p2v

I tried installing the stuff, but the first RPM I tried had a
couple of dependencies and I ran out of time to chase those down.  I am
under the gun on this one - I have to get this system migrated and back
at the colo site.  It was supposed to be turned around by this afternoon
so now I'm very late and won't get it back until tomorrow afternoon.  I
gave up on virt-p2v for this one and I'm doing by hand with an
old-fashioned Windows backup and restore to a fresh VM.  

- Greg

-----Original Message-----
From: libguestfs-bounces redhat com
[mailto:libguestfs-bounces redhat com] On Behalf Of Greg Scott
Sent: Wednesday, August 31, 2011 3:09 PM
To: Brian Gold; Richard W.M. Jones
Cc: libguestfs redhat com
Subject: Re: [Libguestfs] Trying to use virt-p2v

Here is a pointer to a screenshot from my KVM over IP switch:


- Greg

-----Original Message-----
From: Brian Gold [mailto:bgold simons-rock edu] 
Sent: Wednesday, August 31, 2011 2:52 PM
To: Greg Scott; 'Richard W.M. Jones'
Cc: libguestfs redhat com
Subject: RE: [Libguestfs] Trying to use virt-p2v

It's not very clear visually, but you should be able to select
from the destination profile dropdown. Once you've done that you can
fill in
the name, # of cpus, memory, etc. Are you able to get far enough that
even get this screen? http://i.imgur.com/TGggl.jpg

-----Original Message-----
From: Greg Scott [mailto:GregScott Infrasupport com] 
Sent: Wednesday, August 31, 2011 3:44 PM
To: Richard W.M. Jones
Cc: Brian Gold; libguestfs redhat com
Subject: RE: [Libguestfs] Trying to use virt-p2v

Well, progress but I'm not there yet.  

Here are the steps:  On my RHEL6.1 host - I set up a 250 GB logical
volume and put an ext4 filesystem on it and set it up as an NFS share.
I mounted it in the F14 guest, so now I have somewhere to put the stuff
from the F14 guest point of view.  The resulting VM images will end up
as files in a filesystem instead of LVM LVs, but I can live with that.  

On the F14 VM, I did yum install rubygem-virt-p2v and yum install
rubygem-virt-p2v-doc.  And now 

   man virt-p2v-server 

has some text.

On my Windows server, booted from the virt-p2v CD - I connected to the
Fedora VM at IP Address and passed the root credentials.
This time it logged in, but immediately complained there are no profiles
in virt-v2v.conf.  

So back to the virt-p2v-server man pages, I inserted these lines near
the bottom:

<profile name='Temp2003'>
  <storage /mnt/EOCHSTemp2003 format='raw'
  <network type='bridge' name='br0'>

Back to my source server, Connect to the conversion server, and . . . it
hangs.  The mouse cursor moves, but now everything is greyed out, no
files are being created, and the only network traffic is me watching
with iptraf.

-----Original Message-----
From: Richard W.M. Jones [mailto:rjones redhat com] 
Sent: Wednesday, August 31, 2011 2:26 PM
To: Greg Scott
Cc: Brian Gold; libguestfs redhat com
Subject: Re: [Libguestfs] Trying to use virt-p2v

On Wed, Aug 31, 2011 at 01:52:04PM -0500, Greg Scott wrote:
> Oh man, so close!
> [root f14ptov ~]# yum list available | grep p2v
> rubygem-virt-p2v.noarch                   0.8.1-2.fc14
> updates
> rubygem-virt-p2v-doc.noarch               0.8.1-2.fc14
> updates
> virt-p2v-image-builder.noarch             0.8.1-2.fc14
> updates
> [root f14ptov ~]#
> So is rubygem-virt-p2v the piece I'm missing?

Sorry I meant to try all this out today but I got sidetracked.  I'm
definitely going to look at virt-p2v and/or fix it tomorrow.
Hopefully Matt will be able to help us too.

As a side note, latest version should be 0.8.3.  See:



Richard Jones, Virtualization Group, Red Hat
Read my programming blog: http://rwmj.wordpress.com
Fedora now supports 80 OCaml packages (the OPEN alternative to F#)

Libguestfs mailing list
Libguestfs redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]