[Libguestfs] Notes on libguestfs with Ubuntu 12.04 (Precise)

Dale Amon amon at vnl.com
Mon Apr 16 03:21:46 UTC 2012

On Sun, Apr 15, 2012 at 09:05:49PM +0100, Richard W.M. Jones wrote:
> On Sat, Apr 14, 2012 at 09:49:03PM +0100, Richard W.M. Jones wrote:
> > > There is another problem which you may hit, if you add a completely
> > > blank disk to libguestfs (this also affects libguestfs-test-tool):
> > > 
> > >   https://bugs.launchpad.net/ubuntu/+source/linux/+bug/931371
> > >   https://bugzilla.kernel.org/show_bug.cgi?id=42778
> I've now identified the bug, and provided a fix.  The bug in fact is
> in SeaBIOS (not the kernel as originally thought):
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/931371/comments/12
> To recompile SeaBIOS with this fix on Ubuntu 12.04, do:
>   apt-get source seabios
>   cd seabios-0.6.2/debian/patches
>   # Download the patch attached to this email into this directory.
>   echo 0001-Fix-alignment-bug-in-pci_bios_init_root_regions.patch >> series
>   cd ../..
>   debuild -i -uc -us -b
>   cd ..
>   sudo dpkg -i seabios_0.6.2-0ubuntu2_all.deb
> After this, libguestfs should work normally.  (Note you may also need
> to do the febootstrap update from the previous email and rebuild the
> appliance).

I had a bit of a delay on things... I did a dselect 
and didn't realize that it had just updated over top
of the seabios package I had just rebuilt.

I have, with many error messages that may or may not be
specificly relevant to my test disk, seen a virt-rescue
prompt for the first time ever.

I am still not sure whether it has actually 'worked' as
the "vda: vda1 vda2" seems to have only shown me a /dev/vda
but not the partitions. Not sure why yet: a cfdisk does
show that /dev/vda has the correct partition table, etc.

But it is 0420 here and I'm about half past useless myself
at this point. ;-)

And I might just try a kpartx to see what happens.

More information about the Libguestfs mailing list