[Libguestfs] Notes on libguestfs with Ubuntu 12.04 (Precise)

Dale Amon amon at vnl.com
Mon Apr 16 12:26:33 UTC 2012

On Mon, Apr 16, 2012 at 08:37:33AM +0100, Richard W.M. Jones wrote:
> Just do:
> ><rescue> mount /dev/vda1 /sysroot
> and see what it says.

What was going on may have been more complex
than that. I'd already tried that before 
emailing you.

Afterwards I did a kpartx and the partitions
showed up in /dev but would not mount.

Then the /dev/mapper node showed up and I tried
/dev/mapper/vda1 and that worked just fine.

The big problem is that my test monkey is struggling
very hard to handle these new fangled VM's and is
just about choking on them (It's about a 2003 

That means the testing is slow and I have to be
very careful to separate out true bugs from 
what is just very slow hardware by current

I have access to remote systems of far higher
spec, but I can't reach across the Atlantic
to reboot them if things go awry. ;-)


More information about the Libguestfs mailing list