[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] [SOLVED] can`t start guestfsd daemon inside guest

thank you Wanlong Gao :)

From: Wanlong Gao <gaowanlong cn fujitsu com>
To: THO HUYNH <feeliwood yahoo com>
Cc: Richard W.M. Jones <rjones redhat com>; "libguestfs redhat com" <libguestfs redhat com>
Sent: Sunday, 4 March 2012, 21:31
Subject: Re: [Libguestfs] can`t start guestfsd daemon inside guest

On 03/04/2012 10:16 PM, THO HUYNH wrote:

> hi Mr Rich.
> I did it :)
> I can mount, modify the file system on the running guest and the guest update properly :)
> Although I still failed to run the guestfsd daemon inside the guest machine but everything worked properly. I don`t understand why. Can you explain?
> By the way, I used guestmount to mount the running guest.

guestmount can run guestfsd inside the small guest automatically.

-Wanlong Gao

> Thanks :)
> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> *From:* Richard W.M. Jones <rjones redhat com>
> *To:* THO HUYNH <feeliwood yahoo com>
> *Cc:* "libguestfs redhat com" <libguestfs redhat com>
> *Sent:* Sunday, 4 March 2012, 17:09
> *Subject:* Re: can`t start guestfsd daemon inside guest
> On Sat, Mar 03, 2012 at 06:13:48PM -0800, THO HUYNH wrote:
>> <channel type='unix'> <source mode='bind'path='/var/lib/libvirt/qemu/FedoraMini16.libguestfs' /> <target type='virtio'name='org.libguestfs.channel.0'/> </channel>  </devices>
>> but whenever I restart the guest with virt-manager, the clause that
>> I added was deleted.  could you help me please !!!
> As you've pasted it above, the clause is wrong.  It is missing
> spaces in important places (eg. mode='bind'path should be mode='bind' path)
> Start with this simple example:
>      <channel type='unix'>
>        <source mode='bind' path='/tmp/socket'/>
>        <target type='virtio' name='org.libguestfs.channel.0'/>
>      </channel>
> Make sure you copy it accurately.
> Use 'virsh edit <Guest>' to edit the guest XML, and
> 'virsh domxml <Guest>' to check that the clause you tried to
> add is present.
> Rich.
> --
> Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones <http://people.redhat.com/%7Erjones>
> Read my programming blog: http://rwmj.wordpress.com
> Fedora now supports 80 OCaml packages (the OPEN alternative to F#)
> http://cocan.org/getting_started_with_ocaml_on_red_hat_and_fedora
> _______________________________________________
> Libguestfs mailing list
> Libguestfs redhat com
> https://www.redhat.com/mailman/listinfo/libguestfs

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]