[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] virt-v2v: Died at /usr/bin/virt-p2v-server line 411



Le 19/11/2014 22:44, Nicolas Ecarnot a écrit :
Indeed, I see "Connection refused".
Let's investigate on this.

On the conversion server (serv-p2v-adm1), before running all this, I
did a "iptables -F" (and a restart of NFS - not knowing if it was
needed), so I have no rule in iptables now.

Do I have to find a way to increase the verbosity of sshd in
/var/log/secure?

You might want to check that sshd allows port forwarding
('AllowTcpForwarding yes' in /etc/ssh/sshd_config).

This is the next thing I tried after posting my previous reply.
It was commented, and the man page says it is enable by default.
Anyway, I forced it on yes, restarted sshd and tried again but with no
success.

I'm trying the same operation after increasing the sshd log verbosity.

OK, I'm progressing : the ssh issue seems to be gone.
I changed some parameters but not sure which one are relevant.
When comparing with a fresh install, here are the diffs :

root:/etc# diff /etc/ssh/sshd_config /tmp/sshd_config
43a44
> LogLevel DEBUG3
48c49
< #PermitRootLogin yes
---
> PermitRootLogin yes
114,115c115,116
< #AllowTcpForwarding yes
< #GatewayPorts no
---
> AllowTcpForwarding yes
> GatewayPorts yes

The man page specifically says that the -R option won't work unless GatewayPorts is set to yes, and it is NOT able by default. But i don't remember if this was sufficient, because I may have change PermitRootLogin in the same time.

What is sure is that AllowTcpForwading set to yes did not change anything.


Anyway, now, I can see things running for some times. Then failing.

The log file is attached. I have read it quickly. I'm tired. See you tomorrow.

Relevant parts :

--------------------------------------------
libguestfs: trace: hivex_node_get_child = 968144
libguestfs: trace: hivex_node_get_child 968144 "firstboot"
guestfsd: main_loop: new request, len 0x40^M
guestfsd: error: failed: Argument list too long^M
guestfsd: main_loop: proc 355 (hivex_node_get_child) took 0.00 seconds^M
libguestfs: trace: hivex_node_get_child = -1 (error)
virt-v2v: error: libguestfs error: hivex_node_get_child: failed: Argument
list too long
--------------------------------------------

--
Nicolas Ecarnot

Attachment: virt-v2v-conversion-log.txt.gz
Description: application/gzip


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]