[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libguestfs] ocamldep -all seems to break builds on platforms without a native compiler



Hi,

I have been trying to catch up my Debian packages to the current 1.27
branch of libguestfs (and uploaded those packages to experimental), but
apparently the build was broken for architectures where no native OCaml
compiler is available because make wanted to build .cmx files -- see
<https://buildd.debian.org/status/package.php?p=libguestfs&suite=experimental>.

So far mips[1], ppc64el[2], and s390x[3] builds have failed with the same error.

It looks like this commit

,----
| commit a3881445efd04d5fe6da29db8b2d62a30088b9d1
| Author: Richard W.M. Jones <rjones redhat com>
| Date:   Mon Sep 1 22:24:14 2014 +0100
| 
|     Use ocamldep -all option.
`----

caused the build to break. After reverting it, everything worked fine,
at least that's what I found on ppc64el.

What does this -all switch do anyhow? It certainly seems that ocamldep
and/or ocamlfind documentation are lacking.

Cheers,
-Hilko

[1] https://buildd.debian.org/status/fetch.php?pkg=libguestfs&arch=mipsel&ver=1%3A1.27.44-1&stamp=1410672683
[2] https://buildd.debian.org/status/fetch.php?pkg=libguestfs&arch=ppc64el&ver=1%3A1.27.44-1&stamp=1410649974
[3] https://buildd.debian.org/status/fetch.php?pkg=libguestfs&arch=s390x&ver=1%3A1.27.44-1&stamp=1410650468


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]