[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libguestfs] [PATCH] build: Remove support for automake < 1.13.



RHEL 6 has automake 1.13.4.  Since we have stopped supporting RHEL 5,
there is no need for the complex macro to check for older versions of
automake that didn't have 'serial_tests'.
---
 configure.ac | 17 +----------------
 1 file changed, 1 insertion(+), 16 deletions(-)

diff --git a/configure.ac b/configure.ac
index 88f5568..9fde5c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,22 +30,7 @@ AC_SUBST([RELEASE_DATE], [2015-11-04])
 
 AC_CONFIG_AUX_DIR([build-aux])
 
-dnl Initialize automake.  automake < 1.12 didn't have serial-tests and
-dnl gives an error if it sees this, but for automake >= 1.13
-dnl serial-tests is required so we have to include it.  Solution is to
-dnl test for the version of automake (by running an external command)
-dnl and provide it if necessary.  Note we have to do this entirely using
-dnl m4 macros since automake queries this macro by running
-dnl 'autoconf --trace'.
-m4_define([serial_tests], [
-    m4_esyscmd([automake --version | head -1 | awk '
-                     {
-                       split ($NF, version, ".");
-                       if (version[1] == 1 && version[2] >= 12)
-                         print "serial-tests";
-                     }'
-    ])
-])
+dnl Initialize automake.
 AM_INIT_AUTOMAKE(foreign serial_tests subdir-objects) dnl NB: Do not [quote] this parameter.
 
 m4_ifndef([AM_SILENT_RULES], [m4_define([AM_SILENT_RULES],[])])
-- 
2.5.0


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]