[Libguestfs] [PATCH 0/2] rename icat API as download_inode

Matteo Cafasso noxdafox at gmail.com
Tue Mar 29 20:48:06 UTC 2016

"icat" name comes from the employed command line tool which might be replaced later on with a different implementation.

The command name is a bit confusing because it's similar to "cat" but act as "donwload". Therefore I am renaming it with a more clear name.

At the same time I cleaned up a bit the code and improved it's readability and code comments.

This patch is ready for review.
Code available at:


Matteo Cafasso (2):
  rename icat API to download_inode
  updated download_inode tests

 daemon/sleuthkit.c               | 79 ++++++++++++++++++++++------------------
 generator/actions.ml             |  6 ++-
 tests/tsk/Makefile.am            |  2 +-
 tests/tsk/test-download-inode.sh | 53 +++++++++++++++++++++++++++
 tests/tsk/test-icat.sh           | 53 ---------------------------
 5 files changed, 101 insertions(+), 92 deletions(-)
 create mode 100755 tests/tsk/test-download-inode.sh
 delete mode 100755 tests/tsk/test-icat.sh


More information about the Libguestfs mailing list