[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] [PATCH 1/2] Define .errno_is_preserved constant instead of a .errno_is_reliable callback.

On 02/06/2017 08:57 AM, Richard W.M. Jones wrote:
> The callback doesn't make much sense: Could the value change
> per-connection?  Unlikely.  This is a property of the plugin as a
> whole.
> I changed the name to "errno_is_preserved", because it's not about the
> reliability of errno, but about whether errno is preserved across
> calls.

Makes it possible for a regression in C plugins (previously, such
plugins implicitly behaved as if .errno_is_preserved was 1, now such
plugins default to .errno_is_preserved == 0 unless explicitly set and
recompiled against newer headers).  Thus, such plugins will now fail
with EIO where they used to fail with reasonable errno values.

But I guess we can live with that.

Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]