[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] virt-builder resize error



Hi,

On Monday, 20 November 2017 22:57:04 CET David Kaylor wrote:
> I was trying out virt-builder and noticed that in some directories I
> receive an error when the image is resized.
> 
> For example, if I run the following command from my home directory it works
> fine:
> 
> virt-builder rhel-7.4 --size 10G --output test.img
> 
> If I run the same command from /tmp or /vms (my default libvirt pool), I
> see the following in my verbose output:
> 
> virt-resize '--verbose' '--format' 'raw' '--output-format' 'raw' '--expand'
> '/dev/sda3' '--unknown-filesystems' 'error' 'test.img' 'test.img'
> command line: virt-resize --verbose --format raw --output-format raw
> --expand /dev/sda3 --unknown-filesystems error test.img test.img
> virt-resize: error: you cannot use the same disk image for input and output
> 
> Am I doing something wrong or is this possibly a bug? The host I am running
> virt-builder on is Fedora 27.

The only thing it comes into my mind is that there is already a file
called "test.img" in the directories where it fails.

Can you please check that, and provide also a full log virt-builder
with -v -x?

Thanks,
-- 
Pino Toscano

Attachment: signature.asc
Description: This is a digitally signed message part.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]