[Libguestfs] [PATCH v2 nbdkit 2/6] filters: Fix filter.plugin_name method so it returns the name of the plugin.

Eric Blake eblake at redhat.com
Wed Aug 1 14:08:42 UTC 2018


On 08/01/2018 06:10 AM, Richard W.M. Jones wrote:
> This function was completely bogus, the effect being that the
> threadlocal name was always set to the name of the second filter.
> 
> Also fixes an adjacent comment.
> ---
>   src/filters.c | 6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)

ACK


>   
> -/* These are actually passing through to the final plugin, hence
> - * the function names.

Probably refactoring woes, when an earlier version of filters did have 
more than one plugin_ passthrough (or at least the intent of a passthrough).

> +/* This is actually passing the request through to the final plugin,
> + * hence the function name.
>    */
>   static const char *
>   plugin_name (struct backend *b)
>   {
>     struct backend_filter *f = container_of (b, struct backend_filter, backend);
>   
> -  return f->backend.next->name (f->backend.next);
> +  return f->backend.next->plugin_name (f->backend.next);

Yeah, this is better ;)  I'm surprised I didn't notice it.

-- 
Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3266
Virtualization:  qemu.org | libvirt.org




More information about the Libguestfs mailing list