[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libguestfs] [PATCH 7/7] build: stop looking for ocaml-libvirt



We ship our own copy of it, so we do not need the external version.
(Also, the latest upstream version of ocaml-libvirt was already not
usable to build the test harness of v2v.)
---
 m4/guestfs-ocaml.m4 | 4 ----
 1 file changed, 4 deletions(-)

diff --git a/m4/guestfs-ocaml.m4 b/m4/guestfs-ocaml.m4
index e08f40a02..823a4d4fe 100644
--- a/m4/guestfs-ocaml.m4
+++ b/m4/guestfs-ocaml.m4
@@ -127,7 +127,6 @@ if test "x$enable_daemon" = "xyes"; then
 fi
 
 OCAML_PKG_gettext=no
-OCAML_PKG_libvirt=no
 OCAML_PKG_oUnit=no
 ounit_is_v2=no
 have_Bytes_module=no
@@ -140,7 +139,6 @@ AS_IF([test "x$OCAMLC" != "xno"],[
 
     GUESTFS_CREATE_COMMON_GETTEXT_ML([common/mlgettext/common_gettext.ml])
 
-    AC_CHECK_OCAML_PKG(libvirt)
     AC_CHECK_OCAML_PKG(oUnit)
 
     # oUnit >= 2 is required, so check that it has OUnit2.
@@ -164,8 +162,6 @@ AS_IF([test "x$OCAMLC" != "xno"],[
 ])
 AM_CONDITIONAL([HAVE_OCAML_PKG_GETTEXT],
                [test "x$OCAML_PKG_gettext" != "xno"])
-AM_CONDITIONAL([HAVE_OCAML_PKG_LIBVIRT],
-               [test "x$OCAML_PKG_libvirt" != "xno"])
 AM_CONDITIONAL([HAVE_OCAML_PKG_OUNIT],
                [test "x$OCAML_PKG_oUnit" != "xno" && test "x$ounit_is_v2" != "xno"])
 
-- 
2.17.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]