[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] [libnbd] notify API changes (was: Re: [libnbd PATCH 5/6] api: Add new nbd_aio_FOO_notify functions)

On Mon, Jul 15, 2019 at 08:54:41AM -0500, Eric Blake wrote:
> On 7/15/19 6:06 AM, Richard W.M. Jones wrote:
> > (II) Rename nbd_aio_<CMD>_notify to nbd_aio_<CMD>_callback.
> which leaves this as our only sane option to rename. The bikeshedding
> rename sounds fine to me; it's a fairly simple change; it does bump
> API/ABI and will require another release, but we're still at the point
> where we can do it.
> I've also noticed that we have 'struct nbd_handle' and also refer to all
> of our nbd_aio_FOO() results as command handles; that might get
> confusing. My though there is to rename the latter to 'cookie' or 'id'
> or any other term you can think of which would fit (which is more of a
> doc change, and not an actual API change).

"Cookie" sounds fine to me.

> > What do you think?
> Do you want me to go ahead and rename nbd_aio_FOO_notify to
> nbd_aio_FOO_callback?

Sure if you don't mind!  (Or I can do it, as you wish)



Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming and virtualization blog: http://rwmj.wordpress.com
virt-top is 'top' for virtual machines.  Tiny program with many
powerful monitoring features, net stats, disk stats, logging, etc.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]