[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libguestfs] [PATCH nbdkit] python: Drop support for Python 2.



This patch proposes to drop support for Python 2 in nbdkit.

Rather than abruptly drop it everywhere, my proposal is that we point
people to nbdkit 1.14 (the current stable version) if they want to
continue with Python 2 plugins, while gently reminding them of the
upcoming Python 2.7 end of life announcement.

Libnbd never supported Python 2.  Libguestfs in theory supports
Python 2 but I dropped the bindings from Fedora back in March so it's
basically never tested now.  Libvirt also started to prefer Python 3
over Python 2 back in March.

Rich.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]