[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] Debugging libguestfs



Rich,

Thank you for the very quick response. I tried the echo command that you listed and it still gives me the same error:
Inline image

Inline image
Inline image

Any other possible suggestions?
On Monday, October 5, 2020, 02:42:08 PM EDT, Richard W.M. Jones <rjones redhat com> wrote:



On Mon, Oct 05, 2020 at 06:28:06PM +0000, Alexander Prada wrote:
> Here is my output I am getting on my kali machine. I believe that the error is:
>
> guestfsd: error while loading shared libraries: libtsk.so.19: cannot open
> shared object file: No such file or directory
>
> I tried to change the LD_LIBRARY_PATH to numerous locations and libtsk.so.19 is
> inside /usr/lib/x86_64-linux-gnu


As a workaround what you can do is drop in a file into the appliance:

  echo /usr/lib/x86_64-linux-gnu/libtsk.so.19 > /usr/lib/x86_64-linux-gnu/guestfs/supermin.d/zz-libtsk

However this indicates a problem with libguestfs on Kali Linux.
It probably just needs the package to be rebuilt to pick up the
new library name.

Rich.

--
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming and virtualization blog: http://rwmj.wordpress.com
virt-top is 'top' for virtual machines.  Tiny program with many
powerful monitoring features, net stats, disk stats, logging, etc.
http://people.redhat.com/~rjones/virt-top



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]