[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libguestfs] Nbdkit old test plugins link to selinux.so.1



Hi all,

the old 1.2.8 plugins checked into the source repo that are used for testing
the plugin are linking to libselinux.so.1.
This prevents these tests being run on distros without libselinux.
(Arch Linux in my case)

$ ldd tests/old-plugins/x86_64/Linux/v1.2.8/nbdkit-file-plugin.so
	linux-vdso.so.1 (0x00007ffde31d6000)
	libselinux.so.1 => not found
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f72139ed000)

The other old plugins don't require libselinux.

Could the 1.2.8 plugins be replaced with ones not linking to libselinux?

Thanks,
Thomas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]