[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] [libnbd PATCH 3/5] libev: Check for old compiler



On Wed, May 12, 2021 at 03:58:37PM +0200, Martin Kletzander wrote:
> On Mon, May 10, 2021 at 12:03:36AM +0300, Nir Soffer wrote:
> >Do we really support Centos 7? libnbd is available since rhel 8 (2, 3?).
> >Why support older systems?
> >
> 
> Strictly speaking I do not think there is any description of what is
> supported for libnbd.  I just wanted as much as possible to start with,
> but centos7 is now already out.

Upstream I'm trying to keep the various parts of the project compiling
on RHEL 7.  That means things like adding 'requires' to libnbd &
nbdkit tests to compensate for old versions of qemu, and in virt-v2v
not using newer features of OCaml than are present in RHEL 7 (ocaml-4.05).

>From a downstream / RHEL perspective we're not intending to do
anything other than security fixes for RHEL 7.

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming and virtualization blog: http://rwmj.wordpress.com
virt-df lists disk usage of guests without needing to install any
software inside the virtual machine.  Supports Linux and Windows.
http://people.redhat.com/~rjones/virt-df/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]