[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libosinfo] [PATCH 2/2] win7,installer: 'FR-CA' not supported



On Wed, May 14, 2014 at 3:06 PM, Christophe Fergeau <cfergeau redhat com> wrote:
> On Tue, May 13, 2014 at 12:57:44PM +0100, Zeeshan Ali (Khattak) wrote:
>> On Tue, May 13, 2014 at 9:05 AM, Christophe Fergeau <cfergeau redhat com> wrote:
>> > On Mon, May 12, 2014 at 08:29:37PM +0100, Zeeshan Ali (Khattak) wrote:
>> >> Unlike 'EN-GB', 'FR-CA' is not supported at all, neither as UI language
>> >> or locale by win7 installer so lets map 'fr_CA' to 'FR-FR' instead of
>> >> 'FR-CA' so unattended installation doesn't break on 'fr_CA' locale.
>> >
>> > Are you 100% sure about that?
>>
>> No but I first tried to the do the same as with EN-GB: modify FR-CA to
>> FR-FR for *UILanguage but express installation broke. It also breaks
>> with FR-CA as both language and locale.
>
> I'm actually confused as to where you got your FR-CA from. Only the
> values listed in data/datamaps/windows-lang.xml are valid,

Without this patch, you never get 'FR-CA' but rather fr_CA as its not
mapped for lack of a mapping.

> we are not
> going to be able to list all variants in that file.

I'm afraid we'll have to (at least try) if we want the express
installation not to break.

> Just for 'fr', I get
> fr_LU, fr_BE and fr_CH in addition to fr_CA and fr_FR. I expect these
> are an issue as well? Or am I missing something?

I haven't tested those but I'm sure they suffer the same fate.

-- 
Regards,

Zeeshan Ali (Khattak)
________________________________________
Befriend GNOME: http://www.gnome.org/friends/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]