[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libosinfo] [PATCH 2/2] win7,installer: 'FR-CA' not supported



On Wed, May 14, 2014 at 3:46 PM, Christophe Fergeau <cfergeau redhat com> wrote:
> On Wed, May 14, 2014 at 03:14:04PM +0100, Zeeshan Ali (Khattak) wrote:
>> On Wed, May 14, 2014 at 3:06 PM, Christophe Fergeau <cfergeau redhat com> wrote:
>> > I'm actually confused as to where you got your FR-CA from. Only the
>> > values listed in data/datamaps/windows-lang.xml are valid,
>>
>> Without this patch, you never get 'FR-CA' but rather fr_CA as its not
>> mapped for lack of a mapping.
>
> Actually, see osinfo_media_get_languages() documentation:
>
>  * If media is an installer, this property indicates the languages that
>  * can be used during automatic installations.
>
> I don't think fr_CA is ever returned by that method, so that would make it
> an invalid value to use as l10n-language.

Ah that answers my question to you in my previous mail. :)

> Boxes seems to be trying hard
> to return a good value from UnattendedInstaller::get_preferred_language(),
> so I'm not sure how we get to the point where fr_CA gets passed to an
> unattended install script?
> One thing I noticed in get_preferred_language() is that it should probably strip ".UTF-8" when trying to match system locale with media languages, but there is still a fallback in place to return one of the media languages if there is no match.

Actually, i hardcoded 'fr_CA' to be passed as I didn't think hard
enough that its not going to actually happen. Sorry about the false
alarm. :( Thinking about this, I wonder why en_GB gets passed.

-- 
Regards,

Zeeshan Ali (Khattak)
________________________________________
Befriend GNOME: http://www.gnome.org/friends/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]