[Libvir] virDomainLookupByID problem when Root

Daniele Sgandurra dansgan at yahoo.it
Mon Jul 17 16:21:14 UTC 2006

Many thanks for your quick reply!!!
I've tried to download the latest version from:
but I couldn't find the 0.1.3 version (tar.gz). Moreover the file:
is the 0.0.6 version (I think).
I found the RPMS here:
but when I try to do :
yum localinstall libvirt-devel-0.1.3-1.1.i386.rpm libvirt-python-0.1.3-1.1.i386.rpm libvirt-0.1.3-1.1.i386.rpm 
this is the output:
Marking libvirt-python-0.1.3-1.1.i386.rpm as an update to libvirt-python - 0.1.1-1.FC5.i386
Marking libvirt-0.1.3-1.1.i386.rpm as an update to libvirt - 0.1.1-1.FC5.i386
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libvirt-devel.i386 0:0.1.3-1.1 set to be updated
---> Package libvirt.i386 0:0.1.3-1.1 set to be updated
---> Package libvirt-python.i386 0:0.1.3-1.1 set to be updated
--> Running transaction check
--> Processing Dependency: rtld(GNU_HASH) for package: libvirt
--> Processing Dependency: rtld(GNU_HASH) for package: libvirt-python
--> Finished Dependency Resolution
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libvirt
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libvirt-python
(same error with rpm -Uvh)
Any hint/suggestion? Is it possible to download the 0.1.3 version in the tar.gz format?
Thanks for your patience :)

Daniel Veillard <veillard at redhat.com> ha scritto:  On Mon, Jul 17, 2006 at 04:25:12PM +0200, Daniele Sgandurra wrote:
> Hi all!
> I've tried to compile and execute info1.c both as user and as root. As user I have no problem, but as root I get:
> Failed to find Domain 0

  Make sure you are using the latest version, i.e. libvirt-0.1.3 as 0.1.2
had that problem, which was solved since.

> I've traced back the problem to the function:
> virDomainLookupByID(virConnectPtr conn, int id)
> at the line:
> path = xs_get_domain_path(conn->xshandle, (unsigned int) id);
> When root I get path != NULL, otherwise path==NULL;
> if path==NULL then the block after it is executed and everything is ok, otherwise  at the end of the function name=null. (I manually changed path to NULL so that I can run it when root and it works even if info.maxMem it's different from when the program is run as a normal user: it shows -4 instead of 464896).
> It could be a configuration problem of mine (of Xen Store for example)?

  If you use 0.1.3 it won't touch the xenstore backend and use xend access
which is preferable, make sure you upgraded and are using the right libraries.


Daniel Veillard      | Red Hat http://redhat.com/
veillard at redhat.com  | libxml GNOME XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | Rpmfind RPM search engine http://rpmfind.net/

 Chiacchiera con i tuoi amici in tempo reale! 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20060717/6777c807/attachment-0001.htm>

More information about the libvir-list mailing list