[Libvir] Use virsh to monitor qemud

Richard W.M. Jones rjones at redhat.com
Sun Jun 3 13:40:51 UTC 2007

Fabian Deutsch wrote:
> Hey,
> I jsut installed Fedora 7 and tried to install some guests and it worked
> like a charm. I use qemu for full virtulization.
> A couple of minutes later i stumbled across libvirts virtsh. But now I
> wonder how I cna use virtsh to connect to qemud - all I get is something
> like: "Can't connect to hyperisor."


Currently the way things work is that libvirt_qemud needs to be 
"managing" the qemu instances which are running.  It needs to have 
started them, it needs to be still connected to their consoles.

However your error message is a bit different, and seems to indicate 
that virsh is either trying to connect to the Xen hypervisor or cannot 
connect to libvirt_qemud.  It's hard to know because you need to post a 
lot more detail about what you're doing -- the exact virsh command you 
are typing, for example.  You could also try stracing the virsh process 
to see what is failing.


Emerging Technologies, Red Hat - http://et.redhat.com/~rjones/
Registered Address: Red Hat UK Ltd, Amberley Place, 107-111 Peascod
Street, Windsor, Berkshire, SL4 1TE, United Kingdom.  Registered in
England and Wales under Company Registration No. 03798903
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3237 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20070603/74b77ea3/attachment-0001.bin>

More information about the libvir-list mailing list