[Libvir] <disk> <shareable/> has no effect

Daniel Veillard veillard at redhat.com
Fri Nov 16 15:09:19 UTC 2007

On Wed, Nov 14, 2007 at 06:55:31PM +0100, Markus Armbruster wrote:
> Looks like <shareable/> within <disk> has no effect.  I ran virsh
> dumpxml, inserted the <shareable/>, redefined the domain, and ran
> virsh dumpxml again.  No shareable.  I even ran virsh undefine and
> virsh define again, same thing.

  Strange, I noticed that there were no test of the conversion for 
"w!" to and from <shareable/>, so I added tests based on yours but
they work as expected in the conversion routines as tested. So I admit
I'm a bit lost to what could have caused the problem. Since the 
xml dump includes the "w!" I would assume the part going from 
the XML file for creation of the domain worked as expected, but it's
when dumping back the domain that you got the missing  <shareable/>,
right ? Was the domain running at that point ? If on RHEL-5(.1) and
for a defined but non-running domain, the dump routine could use a 
different path.



Red Hat Virtualization group http://redhat.com/virtualization/
Daniel Veillard      | virtualization library  http://libvirt.org/
veillard at redhat.com  | libxml GNOME XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | Rpmfind RPM search engine  http://rpmfind.net/

More information about the libvir-list mailing list