[Libvir] Problem to compile virt-manager in debian etch

Jim Paris jim at jtan.com
Fri Oct 19 18:08:02 UTC 2007

Marco Sinhoreli wrote:
> Hello Jim,
> On 10/19/07, Jim Paris <jim at jtan.com> wrote:
> > > Virt-manager is compiled from mercurial tree but it isn't working. I
> > > don't know why. After run the virt-manager command, it was finished
> > > without output error and the window wasn't created. If you need more
> > > informations about ask me what informations I should sent.
> >
> > I ran into that too -- make sure you have the "gtk-vnc" package
> > installed, it's a relatively new requirement of virt-manager and
> > there are no errors printed if it fails to load [1].
> >
> I got, and compiled the gtk-vnc source. I have tried 'gvncviewer' in
> example directory and it is working well. I cleaned, and recompiled
> the virt-manager source but the virt-manager command continues not
> working. If you have same idea please, say me.

Hmm, I don't know what else it could be.  Could you try 

  virt-manager --no-dbus --no-fork

and if that still quits right away, 

  strace -f -o /tmp/log virt-manager --no-dbus --no-fork

and then send me a copy of /tmp/log.  (If it's large, just mail it
directly to me instead of the list).


More information about the libvir-list mailing list